We are currently performing an upgrade to our software. This upgrade will bring MediaWiki from version 1.31 to 1.33. While the upgrade is being performed on your wiki it will be in read-only mode. For more information check here.

System requirements

From Tower 57 Wiki
Jump to: navigation, search

Windows[edit | edit source]

MINIMUM:

OS: Windows 7,8 or 10
Processor: Intel(R) Core(TM)2 Duo 2.4, AMD Athlon(TM) X2 2.8 Ghz
Memory: 2 GB RAM
Graphics: Geforce 9600 GS, Radeon, HD4000, Shader Model 3.0, 512 MB
Sound Card: DirectX compatible

RECOMMENDED:

OS: Windows 7,8 or 10
Processor: Intel(R) Core(TM)2 Duo 2.4, AMD Athlon(TM) X2 2.8 Ghz
Memory: 4 GB RAM
Graphics: Geforce 9600 GS, Radeon, HD4000, Shader Model 3.0, 512 MB
Sound Card: DirectX compatible

Mac OS X[edit | edit source]

MINIMUM:

OS: 10.6
Processor: Intel(R) Core(TM)2 Duo 2.4, AMD Athlon(TM) X2 2.8 Ghz
Memory: 2 GB RAM
Sound Card: Integrated

RECOMMENDED:

OS: 10.6
Processor: Intel(R) Core(TM)2 Duo 2.4, AMD Athlon(TM) X2 2.8 Ghz
Memory: 4 GB RAM
Sound Card: Integrated